こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

OSが起動しません

以前HDDを二つ接続し、Cドライブ(PrimaryMaster)にWindowsXPが入っている状態で、もう一つのHDD(PrimarySlave)にFedoraCore3をインストールしました。

その後FedoraCore3の動作が不安定なのでCドライブのみでWindowsを起動しようとすると、"GRUB"と出て全くOSが立ち上がりません。

ちなみに全く別のHDDをPrimarySlave側に接続すると、"GRUB Hard disk error"と出ます。
もうLinuxは必要ないので、Windowsが通常起動するようにしたいと思っています。

Linuxインストール時のブート(パーティションかな?)の設定のためにGRUBが入ってしまい、起動できないのだと思いましたので、別のHDDにWindowsXPを新しくインストールし、そちらで起動した後、デスクトップからの操作で回復コンソールを(OS起動時に)選択できる状態にしました。
その後ドライブ指定してfixmbr及びfixbootを試みましたが、事態が改善しません。
もとより、新しいHDDを使わなければ回復コンソールが使えないというのも変な気はするのですが・・・
HDD内のデータはそのまま残っていたので、物理的な問題はないと思います。

なんとかWindowsを立ち上げたいのですが、自分一人ではこれが精一杯でした。非常に困っています。どうか知恵をお貸しください。

投稿日時 - 2005-08-20 16:09:53

QNo.1592641

すぐに回答ほしいです

質問者が選んだベストアンサー

GRUBが壊れているというよりも、単に
FedoraCoreインストール時にGRUBから
Windowsも起動できる設定にしていなかっただけだと思います。
このへんはデュアルブートのFAQだと言えます。

が、fixmbrで修復できないというのは異状ですね。
fixmbrで誤操作や誤動作があったか、エラー終了している気がします。
M/Bの設定でMBR書き換えができない場合もあったような気がする。


第三の選択肢として、汎用のブートマネージャーを使う手があります。
が、市販品を購入すべき状況かわかりませんから、無償の
MBMを使ってみてはどうでしょう?

MBMはFDに書き込んで起動FDを作成できますから
そのFDからHDDへと導入することができます。
http://www.vector.co.jp/soft/dos/util/se035596.html

投稿日時 - 2005-08-21 11:35:46

お礼

確かに、FedoraCoreインストール時のデュアルブートの設定に問題はあったかもしれません。

問題の件ですが、解決しました。今までは別のHDDから起動し、そちらのOSで設定した回復コンソールを使っていたのですが、今回は問題のHDのみを接続し、OSのCDから再インストールしたらうまくいきました。

以前も似たようなことはやっていたのですが、どうもHomeとProでは回復方法やドライブ設定が異なるようで(詳しくないのでよく分かりませんが)、それが原因で上手くいかなかったようです。

ちなみに、こちらに書き込む際に使用していたパソコンではFDが使えなかったので試すことは出来ませんでしたが、ご指示頂いたMBMによる修復方法もおそらく有効だと思います。

ご丁寧に、回答ありがとうございました。

投稿日時 - 2005-08-21 15:14:44

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

MBRにインストールされているGRUBが壊れているだけであれば、GRUBを再インストールすれば直りそうな気がしなくもありませんが・・・。

GRUBを再インストールするにはLinuxのインストールCDを入れて、boot: のところで linux rescue と入力して rescue モードで起動。以降、English, JP106 を選択して、コマンドラインが表示されたら

# chroot /mnt/sysimage
# grub-install

とすればとりあえずはGRUBを再インストールできるはずです。

投稿日時 - 2005-08-20 16:34:17

お礼

回答ありがとうございます。
現在はLinuxの入ったHDDが無いのでFedoraCoreのレスキューモードで復旧できるか不安でしたが、一応やってみました。結果として進展はなく、"caroot: cannot change root dictionary to mnt/sysimage: No such file or dictionary"という風に表示されてしまいます。
何かお気付きの点がありましたら、何卒ご指摘下さい。

投稿日時 - 2005-08-20 21:48:45

あなたにオススメの質問