こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

更新phpで画像を投稿するとエラー

いつもお世話になっております。
今回はphpの事で困っております。

投稿型で更新の出来る新着情報phpがあります。
以前までなんの問題なく動いていたのですが、いつものように画像を更新しようとすると
「Fatal error: imagecreatetruecolor(): requires GD 2.0 or later…」のエラーが出るようになってしまいました。

かなり前に出たことがあるのですが、これを修復したプログラムを貰って、解決し、今まで動いていたのですが…
突然またエラーが再発してしまいました。

どなたか解決方法を教えてください。
宜しくお願い致します。

投稿日時 - 2007-08-21 11:41:02

QNo.3273050

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

前回の回答にも書きましたがご質問者様の「ご利用環境」が
分からないので、お答えできないのです。

もしご質問者様がそれをご存知ないのであれば、知っている方に
聞いていただくしかありません。
レンタルサーバを利用しているのであればその会社に、どなたか
お知り合いの方に設定していただいたのであればその方に。

投稿日時 - 2007-08-22 07:28:16

補足

kiyusaさんの言う「ご利用環境」とはマシンのことですか?
サーバーのことですか?
マシンはmacOSXでサーバーはclasscatというレンタルサーバーです。
kiyusaさんの言う「知っている方」がいないのでこちらで質問させて頂いたのですが、調べ方が分からない・お答え出来ないということなので質問を取り下げさせていただきます。

投稿日時 - 2007-08-23 11:03:49

ANo.1

ご利用の環境がまったく書かれていないので、以下のマニュアルの内容を
確認してください。
#PHPのバージョン、GDのバージョン

参考URL:http://jp.php.net/manual/ja/function.imagecreatetruecolor.php

投稿日時 - 2007-08-21 12:33:52

お礼

すみません。
別ファイルを使用する事で自己解決しましたが、原因が分からないままなので引き続き教えてください。
URL参照しましたがPHPのバージョン、GDのバージョンの調べ方が分かりません…

投稿日時 - 2007-08-21 16:35:44

あなたにオススメの質問