こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

VMwareでのLinuxについて

ホストOSがWindows10,ゲストがLinux(xbuntu)でVMwarePlayer 15という環境ですが、2点問題があります。

1.ゲストを立ち上げても音がでない。そのため使えなくはないですが、味気ないです。メッセージとしてもドライバが動作しないということになっています。音が出るように変更できるのでしょうか。なお、この問題は数年前からどのLinuxであっても続いています。問題が解消されたことがありません。

2.ブラウザ(ファイヤーフォックス)がにつながりません。ただし、sudo apt updateなどは問題なく動作し、pingも通りますのでネットワークにはつながっていることになり、ブラウザだけの設定ですが、そうするとプロキシかと思いますが、設定はしているつもりでスペルミスなどもないと思います。あと調査するところがあるでしょうか。
よろしくお願いします。

投稿日時 - 2020-01-23 16:24:59

QNo.9704814

困ってます

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

VMware Toolですが、一般的なLinuxの場合、開発環境(コンパイラ、カーネルヘッダなど)をインストールしておく必要があります。
インストールしておかないと、エラーメッセージが表示されますが、読み飛ばしてしまうと正常終了します。
これらのパッケージがインストールされているか確認し、されていない場合はVMware Toolsのインストール(ビルド)に失敗していますので、パッケージをインストール後、VMware Toolsを再ビルドしてください。

https://kb.vmware.com/articleview?docid=1022525&lang=ja
> 以下のパッケージは VMware Tools に依存しています。 これらは VMware Tools をインストールする前に Linux オペレーティング システムで使用可能である必要があります。
> gcc
> binutils
> make
> kernel sources

> ブラウザだけの設定ですが、そうするとプロキシかと思いますが、設定はしているつもりでスペルミスなどもないと思います。
Proxyの設定が必要な環境でご利用でしたら、その環境のネットワーク管理者にご相談ください。

投稿日時 - 2020-02-06 09:00:57

ANo.1

>1.ゲストを立ち上げても音がでない
 問題なく音は出ますので一度下記を確認してみてください。
 ・仮想マシン設定 ハードウェアーのサウンドカードの設定を見直す
 ・VWware Tool が正常に動作していかを確認する
>2.ブラウザ
 ソフトの問題かネットワーク設定の問題かと思いますので再インストールや他のブラウザーに変更する、URLをIPアドレスで指定する等で模索してみてください。

投稿日時 - 2020-01-24 07:11:55

お礼

回答ありがとうございます。サウンドカードの方ですが、少し進展があり、サウンドを認識してくれるパソコンが出てきました。ただし、そのパソコンに対して何らかの特別な措置をしたわけでなく、何もしなくても勝手に動作してくれました。インストールプロセスの中で特段サウンドに対してケアするところはないように思います(ちょっとだけあった気もしますが)。
そのため、うまくいく・いかないの境界がわかりません。VmwareToolsですが、設定で間違うところがあるでしょうか。tar xzvfで解凍して、そのあと、sudo ./install.plのようなコマンドですね。しかし、その後、大量のYes/Noに答えていくのでそこにあるかもしれませんが。私はここですべてデフォルト、すなわちreturnだけです。以上のような状況なのでサウンド設定で素通りしたか、あとは相性問題、すなわちハードウェアの適合・不適合ぐらいしか原因が思いつきません。

投稿日時 - 2020-01-24 13:33:18